It's ALIIIIVE!

Submitted by hrm on 13 April, 2008 - 18:55

Vlad is now alive again.

After spending a significant chunk of Saturday grubbing around on the floor, elbow-deep in computers (think James Herriot, only less gooey and with sharper edges), I've diagnosed vlad's problems: At least one of the two hard drives in the RAID-1 array containing my home directory has media errors, and the motherboard has decided to stop working entirely.

After running the hard drives overnight in my desktop machine, I had a second hard disk error on the other RAID-1 drive -- this time a timeout error, not a media error. Oddly, all of the drives passed a SMART self-test last night, so either SMART tests aren't very good, or there's something else wrong.

I took the opportunity, while swapping round processors, to put the honking great (but very quiet) heatsink from vlad into selene, the desktop.

Today was a trip to Novatech in Portchester, for a couple of new hard drives for the RAID array, a new motherboard, and a heatsink/fan unit. I put the whole lot together again -- discovering (a) I didn't need the heatsink/fan after all, as I had one already that I could use, (b) one of the hard drives had the wrong interface (who uses PATA these days, dammit?), (c) they changed the spec on the ATX power connector (trip to Maplin for a 20-to-24-pin converter). Putting the whole thing back together and turning it on resulted in a very nasty-looking random flickering from the power LED, and static from the speaker. That went away when I used the spare PSU I'd borrowed from work. I'll be testing my old one tomorrow with Damian's test kit.

I put in some case fans I had lying around, too. It now makes a lot more noise than it used to, which is a pain, but it should keep the innards nice and cool. I need to investigate getting some quieter fans and fan controllers, I think. Possibly also getting a dremel to take out the piercing on the back of the case to improve the airflow from the case fans. Something for another day, though.